summaryrefslogtreecommitdiffstats
path: root/tdelfeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-12-31 17:36:26 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-12-31 17:36:26 -0600
commitd6a4fe9ca855e094bbfe2e1ba1bba565557b1891 (patch)
tree7a2aed881ccd01bcc47a676d5aa9c6076b2389f2 /tdelfeditor/CMakeLists.txt
parent43f19fb8a02775dca1d0701f7a7eb3ce775439ff (diff)
downloadtdelibs-d6a4fe9ca855e094bbfe2e1ba1bba565557b1891.tar.gz
tdelibs-d6a4fe9ca855e094bbfe2e1ba1bba565557b1891.zip
Add tdelfeditor
Diffstat (limited to 'tdelfeditor/CMakeLists.txt')
-rw-r--r--tdelfeditor/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/tdelfeditor/CMakeLists.txt b/tdelfeditor/CMakeLists.txt
new file mode 100644
index 000000000..c18421cef
--- /dev/null
+++ b/tdelfeditor/CMakeLists.txt
@@ -0,0 +1,33 @@
+#################################################
+#
+# (C) 2011 Timothy Pearson
+# kb9vqf (AT) pearsoncomputing.net
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${LIBR_INCLUDEDIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${LIBR_LIBDIR}
+)
+
+
+##### tdelfeditor ################################
+
+tde_add_executable( tdelfeditor
+ SOURCES tdelfeditor.cpp
+ DESTINATION ${BIN_INSTALL_DIR}
+ LINK ${TQT_LIBRARIES} ${LIBR_LIBRARIES} tdecore-shared
+)