summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9bce50de8..53cfe8119 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -102,6 +102,8 @@ OPTION( WITH_KDE4_MENU_SUFFIX "Add [KDE4] tag to KDE4 menu items" OFF )
OPTION( WITH_ASPELL "Enable aspell support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_HSPELL "Enable hspell support" ${WITH_ALL_OPTIONS} )
+OPTION( WITH_TDEICONLOADER_DEBUG "Enable debugging in TDEIconLoader class" OFF )
+
##### set PKG_CONFIG_PATH #######################
@@ -953,6 +955,13 @@ if( WITH_HSPELL )
endif( WITH_HSPELL )
+##### enable TDEIconLoader debugging ############
+
+if ( WITH_TDEICONLOADER_DEBUG )
+ set ( TDEICONLOADER_DEBUG 1 )
+endif ( WITH_TDEICONLOADER_DEBUG )
+
+
##### write configure files #####################
configure_file( config.h.cmake config.h )