summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8758ddea4..18c6dcfeb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -694,7 +694,11 @@ endif( )
if( WITH_CRYPTSETUP )
pkg_search_module( LIBCRYPTSETUP libcryptsetup )
if( NOT LIBCRYPTSETUP_FOUND )
+ find_library( LIBCRYPTSETUP_LIBRARY cryptsetup )
+ if( NOT LIBCRYPTSETUP_LIBRARY )
message(FATAL_ERROR "\ncryptsetup support was requested, but libcryptsetup was not found on your system" )
+ endif ( NOT LIBCRYPTSETUP_LIBRARY )
+ set( LIBCRYPTSETUP_LIBRARIES ${LIBCRYPTSETUP_LIBRARY} )
endif( NOT LIBCRYPTSETUP_FOUND )
set( HAVE_CRYPTSETUP 1 )
if ( HAVE_CRYPTSETUP )