summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8f8be8971..ba552432a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -956,6 +956,11 @@ install( FILES
##### pkg-config #################################
+execute_process(
+ COMMAND awk "/^#define TDE_VERSION_MAJOR/,/^#define TDE_VERSION_RELEASE/{ v[++i]=$3 }; END { print v[1]\".\"v[2]\".\"v[3] };"
+ INPUT_FILE ${CMAKE_SOURCE_DIR}/tdecore/tdeversion.h
+ OUTPUT_VARIABLE TDE_RELEASE_NUM
+ OUTPUT_STRIP_TRAILING_WHITESPACE )
configure_file( tdelibs.pc.cmake tdelibs.pc @ONLY )
install( FILES ${CMAKE_CURRENT_BINARY_DIR}/tdelibs.pc DESTINATION ${PKGCONFIG_INSTALL_DIR} )