summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 45f161b0e..11d3c4bfe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -679,6 +679,12 @@ if( WITH_XCOMPOSITE )
else( WITH_XCOMPOSITE )
tde_message_fatal( "xcomposite support was requested, but xcomposite was not found on your system" )
endif( XCOMPOSITE_FOUND )
+
+ # xext (tderandr, tdestyles/keramik, tdeui)
+ pkg_search_module( XEXT xext )
+ if( NOT XEXT_FOUND )
+ tde_message_fatal( "xext is required for xcomposite support, but was not found on your system" )
+ endif( )
endif( WITH_XCOMPOSITE )