summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b63914aa..6d809d29e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1245,6 +1245,30 @@ if( NOT WIN32 AND NOT ICEAUTH_PATH )
endif( NOT WIN32 AND NOT ICEAUTH_PATH )
+##### find the rgb.txt file
+
+message( STATUS "Looking for rgb.txt" )
+find_file( PATH_RGB rgb.txt
+ PATHS
+ /usr/share/X11
+ /usr/X11R6/lib/X11
+ /usr/openwin/lib/X11
+)
+if( PATH_RGB )
+ message( STATUS "Found rgb.txt file: ${PATH_RGB}" )
+ set( X11_RGBFILE "${PATH_RGB}" )
+endif()
+
+
+##### Look for xmllint
+
+find_program( XMLLINT_EXE xmllint )
+if( XMLLINT_EXE )
+ set( XMLLINT "${XMLLINT_EXE}" )
+ message( STATUS "Found xmllint: ${XMLLINT}" )
+endif()
+
+
##### write configure files #####################
configure_file( config.h.cmake config.h )