summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a0184166..84ceb566d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,11 +243,23 @@ if( HAVE_SYS_TIME_H AND HAVE_TIME_H )
endif( HAVE_SYS_TIME_H AND HAVE_TIME_H )
if( HAVE_SYS_ACL_H )
- set( USE_POSIX_ACL 1 )
+ check_include_file( "acl/libacl.h" HAVE_ACL_LIBACL_H )
+ if( HAVE_ACL_LIBACL_H )
+ check_library_exists( acl acl_init "" HAVE_ACL_INIT )
+ if( HAVE_ACL_INIT AND HAVE_SYS_XATTR_H )
+ set( USE_POSIX_ACL 1 )
+ set( HAVE_NON_POSIX_ACL_EXTENSIONS 1 )
+ set( ACL_LIBRARIES acl attr )
+ endif( HAVE_ACL_INIT AND HAVE_SYS_XATTR_H )
+ else( HAVE_ACL_LIBACL_H )
+ check_library_exists( c acl_init "" HAVE_ACL_INIT )
+ if( HAVE_ACL_INIT )
+ set( USE_POSIX_ACL 1 )
+ set( ACL_LIBRARIES c )
+ endif( HAVE_ACL_INIT )
+ endif( HAVE_ACL_LIBACL_H )
endif( HAVE_SYS_ACL_H )
-check_include_file( "acl/libacl.h" HAVE_NON_POSIX_ACL_EXTENSIONS )
-
check_include_file( "valgrind/memcheck.h" HAVE_VALGRIND_MEMCHECK_H )
check_include_file( "values.h" HAVE_VALUES_H )
check_include_file( "X11/extensions/shape.h" HAVE_X11_EXTENSIONS_SHAPE_H )