summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/flac/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commite2de64d6f1beb9e492daf5b886e19933c1fa41dd (patch)
tree9047cf9e6b5c43878d5bf82660adae77ceee097a /kfile-plugins/flac/Makefile.am
downloadtdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.tar.gz
tdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdemultimedia@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfile-plugins/flac/Makefile.am')
-rw-r--r--kfile-plugins/flac/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/kfile-plugins/flac/Makefile.am b/kfile-plugins/flac/Makefile.am
new file mode 100644
index 00000000..bb3a08e3
--- /dev/null
+++ b/kfile-plugins/flac/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for FLAC file meta info plugin
+
+# set the include path for X, qt, KDE and TagLib
+INCLUDES = $(all_includes) $(taglib_includes)
+
+# these are the headers for your project
+noinst_HEADERS = kfile_flac.h
+
+kde_module_LTLIBRARIES = kfile_flac.la
+
+kfile_flac_la_SOURCES = kfile_flac.cpp
+kfile_flac_la_LDFLAGS = $(all_libraries) $(taglib_libs) -module $(KDE_PLUGIN)
+kfile_flac_la_LIBADD = $(LIB_KIO)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) kfile_flac.cpp -o $(podir)/kfile_flac.pot
+
+services_DATA = kfile_flac.desktop
+servicesdir = $(kde_servicesdir)