summaryrefslogtreecommitdiffstats
path: root/noatun/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-30 00:57:03 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-30 01:05:29 +0200
commitd11ce98ed0b2a0508fcfbe8bb0f956e3f671ad0d (patch)
tree060933b7cc6b5aa928a37c4868330f58fb5b6294 /noatun/CMakeLists.txt
parent77d1049eb65f4d8bd24351c5c1a8d6344bf3ec62 (diff)
downloadtdemultimedia-d11ce98ed0b2a0508fcfbe8bb0f956e3f671ad0d.tar.gz
tdemultimedia-d11ce98ed0b2a0508fcfbe8bb0f956e3f671ad0d.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit ff3f2006ce72b2edabc534188a4ad006e89b4f84)
Diffstat (limited to 'noatun/CMakeLists.txt')
-rw-r--r--noatun/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/noatun/CMakeLists.txt b/noatun/CMakeLists.txt
index df9f15b4..dc2a6817 100644
--- a/noatun/CMakeLists.txt
+++ b/noatun/CMakeLists.txt
@@ -56,8 +56,13 @@ add_custom_target( noatun.api
##### other data ################################
-install( FILES noatun.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE noatun.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/noatun-desktops
+)
+
install( FILES noatun.upd DESTINATION ${DATA_INSTALL_DIR}/tdeconf_update )
+
install(
FILES
preset.dance preset.jazz preset.metal preset.trance preset.zero