summaryrefslogtreecommitdiffstats
path: root/tdeioslave/audiocd/plugins/wav/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
commit793cf2dff35dffe3ec4c7b24252947dde758a1b2 (patch)
tree7d9972d99ed281a36418ae9f5fc128e3c951532c /tdeioslave/audiocd/plugins/wav/Makefile.am
parent04f764aaf273340e1d5811d4216dd8127cacc5db (diff)
downloadtdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.tar.gz
tdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/audiocd/plugins/wav/Makefile.am')
-rw-r--r--tdeioslave/audiocd/plugins/wav/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tdeioslave/audiocd/plugins/wav/Makefile.am b/tdeioslave/audiocd/plugins/wav/Makefile.am
new file mode 100644
index 00000000..82e6ab28
--- /dev/null
+++ b/tdeioslave/audiocd/plugins/wav/Makefile.am
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = -I$(srcdir)/.. $(all_includes)
+
+INCLUDES = -I$(top_srcdir)/libkcddb
+
+kde_module_LTLIBRARIES = libaudiocd_encoder_wav.la
+
+libaudiocd_encoder_wav_la_SOURCES = encoderwav.cpp encodercda.cpp
+
+libaudiocd_encoder_wav_la_LIBADD = $(LIB_KIO) ../libaudiocdplugins.la $(CDPARANOIA_LIBS)
+
+libaudiocd_encoder_wav_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries)
+
+pluginsdir = $(kde_datadir)/audiocd/plugins
+
+METASOURCES = AUTO