summaryrefslogtreecommitdiffstats
path: root/xine_artsplugin/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commite2de64d6f1beb9e492daf5b886e19933c1fa41dd (patch)
tree9047cf9e6b5c43878d5bf82660adae77ceee097a /xine_artsplugin/Makefile.am
downloadtdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.tar.gz
tdemultimedia-e2de64d6f1beb9e492daf5b886e19933c1fa41dd.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdemultimedia@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'xine_artsplugin/Makefile.am')
-rw-r--r--xine_artsplugin/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/xine_artsplugin/Makefile.am b/xine_artsplugin/Makefile.am
new file mode 100644
index 00000000..799bff29
--- /dev/null
+++ b/xine_artsplugin/Makefile.am
@@ -0,0 +1,25 @@
+INCLUDES= -I$(kde_includes)/arts $(all_includes) $(XINE_CFLAGS)
+
+AM_CFLAGS = -U__STRICT_ANSI__
+
+lib_LTLIBRARIES = libarts_xine.la
+
+libarts_xine_la_SOURCES = xinePlayObject.cc \
+ xinePlayObject_impl.cpp \
+ audio_fifo_out.c
+libarts_xine_la_LDFLAGS = $(all_libraries) -module -no-undefined -pthread
+libarts_xine_la_LIBADD = $(XINE_LIBS) $(LIB_X11) $(LIB_XEXT) \
+ -lkmedia2_idl -lsoundserver_idl -lartsflow
+
+libarts_xine_la_METASOURCES = AUTO
+
+$(srcdir)/xinePlayObject_impl.cpp: xinePlayObject.h
+xinePlayObject.cc xinePlayObject.h: $(srcdir)/xinePlayObject.idl
+ $(MCOPIDL) -I$(kde_includes)/arts $(srcdir)/xinePlayObject.idl
+
+noinst_HEADERS = xinePlayObject_impl.h audio_fifo_out.h
+
+mcopclassdir = $(libdir)/mcop
+mcopclass_DATA = xineAudioPlayObject.mcopclass xineVideoPlayObject.mcopclass
+
+SUBDIRS = tools