summaryrefslogtreecommitdiffstats
path: root/mpeglib/example/yaf/yafxplayer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpeglib/example/yaf/yafxplayer/CMakeLists.txt')
-rw-r--r--mpeglib/example/yaf/yafxplayer/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/mpeglib/example/yaf/yafxplayer/CMakeLists.txt b/mpeglib/example/yaf/yafxplayer/CMakeLists.txt
new file mode 100644
index 00000000..95f2c5b3
--- /dev/null
+++ b/mpeglib/example/yaf/yafxplayer/CMakeLists.txt
@@ -0,0 +1,53 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+add_definitions(
+ -DDIRECT_INCLUDE
+)
+
+
+##### yafplayer (library) #######################
+
+tde_add_library( yafxplayer SHARED
+ SOURCES
+ commandTableXPlayer.cpp
+ inputDecoderXPlayer.cpp
+ xplayer_control.cpp
+ runtimeTableXPlayer.cpp
+ inputDecoderYAF.cpp
+ yafOutputStream.cpp
+ LINK
+ yafcore-shared
+ mpeg-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install(
+ FILES
+ inputDecoderYAF.h
+ inputDecoderXPlayer.h
+ yafOutputStream.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/mpeglib/util/yaf/yafxplayer
+)