summaryrefslogtreecommitdiffstats
path: root/mpeglib/lib/frame/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpeglib/lib/frame/CMakeLists.txt')
-rw-r--r--mpeglib/lib/frame/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/mpeglib/lib/frame/CMakeLists.txt b/mpeglib/lib/frame/CMakeLists.txt
new file mode 100644
index 00000000..e8517950
--- /dev/null
+++ b/mpeglib/lib/frame/CMakeLists.txt
@@ -0,0 +1,44 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### mpeg_frame (library) ######################
+
+tde_add_library( mpeg_frame STATIC_PIC
+ SOURCES
+ pcmFrame.cpp
+ audioFrame.cpp floatFrame.cpp frame.cpp
+ frameQueue.cpp IOFrameQueue.cpp
+ audioFrameQueue.cpp framer.cpp
+ rawDataBuffer.cpp rawFrame.cpp
+)
+
+
+##### other data ################################
+
+install(
+ FILES
+ pcmFrame.h audioFrame.h
+ floatFrame.h frameQueue.h frame.h
+ IOFrameQueue.h audioFrameQueue.h
+ framer.h rawDataBuffer.h rawFrame.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/mpeglib/frame
+)