summaryrefslogtreecommitdiffstats
path: root/oggvorbis_artsplugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'oggvorbis_artsplugin/Makefile.am')
-rw-r--r--oggvorbis_artsplugin/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/oggvorbis_artsplugin/Makefile.am b/oggvorbis_artsplugin/Makefile.am
new file mode 100644
index 00000000..aeec6205
--- /dev/null
+++ b/oggvorbis_artsplugin/Makefile.am
@@ -0,0 +1,23 @@
+# $Id$
+
+INCLUDES= -I$(kde_includes)/arts $(all_includes)
+
+noinst_HEADERS = oggPlayObject_impl.h
+
+lib_LTLIBRARIES = liboggarts.la
+liboggarts_la_COMPILE_FIRST = oggarts.h
+liboggarts_la_SOURCES = oggarts.cc oggPlayObject_impl.cpp
+liboggarts_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+liboggarts_la_LIBADD = -lkmedia2_idl -lsoundserver_idl -lartsflow -lvorbisfile -lvorbis -logg
+liboggarts_la_METASOURCES = AUTO
+
+oggarts.mcopclass: oggarts.h
+oggarts.mcoptype: oggarts.h
+oggarts.cc oggarts.h: $(srcdir)/oggarts.idl $(MCOPIDL)
+ $(MCOPIDL) -t -I$(kde_includes)/arts $(srcdir)/oggarts.idl
+
+mcoptypedir = $(libdir)/mcop
+mcoptype_DATA = oggarts.mcoptype oggarts.mcopclass
+
+mcopclassdir = $(libdir)/mcop/Arts
+mcopclass_DATA = oggPlayObject.mcopclass