summaryrefslogtreecommitdiffstats
path: root/kdict/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kdict/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kdict/Makefile.am')
-rw-r--r--kdict/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/kdict/Makefile.am b/kdict/Makefile.am
new file mode 100644
index 00000000..5cb60755
--- /dev/null
+++ b/kdict/Makefile.am
@@ -0,0 +1,33 @@
+## Makefile.am for kdict
+
+KDE_CXXFLAGS = $(USE_THREADS)
+
+SUBDIRS = applet pics
+
+bin_PROGRAMS =
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = kdict.la
+
+# set the include path for X, qt and KDE
+AM_CPPFLAGS = $(all_includes)
+
+kdict_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -module $(KDE_PLUGIN)
+kdict_la_LIBADD = $(LIB_KFILE) $(LIB_KHTML) $(LIBPTHREAD) $(LIBRESOLV)
+kdict_la_SOURCES = dcopinterface.skel main.cpp actions.cpp dict.cpp options.cpp \
+ queryview.cpp toplevel.cpp sets.cpp matchview.cpp application.cpp
+
+# these are the headers for your project
+noinst_HEADERS = actions.h dict.h options.h queryview.h toplevel.h sets.h matchview.h application.h
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/kdict.pot
+
+KDE_ICON = AUTO
+
+# this is where the kdelnk file will go
+xdg_apps_DATA = kdict.desktop
+
+rcdir = $(kde_datadir)/kdict
+rc_DATA = kdictui.rc