summaryrefslogtreecommitdiffstats
path: root/knewsticker/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /knewsticker/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'knewsticker/Makefile.am')
-rw-r--r--knewsticker/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/knewsticker/Makefile.am b/knewsticker/Makefile.am
new file mode 100644
index 00000000..eea97be4
--- /dev/null
+++ b/knewsticker/Makefile.am
@@ -0,0 +1,34 @@
+SUBDIRS = common kntsrcfilepropsdlg knewstickerstub
+INCLUDES = -I$(top_srcdir)/knewsticker/common $(all_includes)
+
+kde_module_LTLIBRARIES = knewsticker_panelapplet.la
+
+noinst_HEADERS = newsscroller.h knewsticker.h
+
+METASOURCES = AUTO
+
+knewsticker_panelapplet_la_SOURCES = newsscroller.cpp \
+ knewsticker.cpp knewsticker.skel \
+ knewstickerconfig.cpp knewstickerconfigwidget.ui \
+ newssourcedlgimpl.cpp newssourcedlg.ui
+knewsticker_panelapplet_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+knewsticker_panelapplet_la_LIBADD = common/libknewstickercommon.la \
+ $(LIB_KIO) $(LIB_KDEUI)
+
+appdatadir = $(kde_datadir)/knewsticker
+appdata_DATA = eventsrc
+
+updatedir = $(kde_datadir)/kconf_update
+update_DATA = knewsticker.upd
+update_SCRIPTS = knt-0.1-0.2.pl
+
+lnkdir = $(kde_datadir)/kicker/applets
+lnk_DATA = knewsticker.desktop
+
+xdg_apps_DATA = knewsticker-standalone.desktop
+
+KDE_ICON = AUTO
+
+messages: rc.cpp
+ $(EXTRACTRC) *.ui */*.ui >> rc.cpp
+ $(XGETTEXT) *.cpp *.h */*.cpp */*.h -o $(podir)/knewsticker.pot