summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/texteffect/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /kopete/plugins/texteffect/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/plugins/texteffect/Makefile.am')
-rw-r--r--kopete/plugins/texteffect/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kopete/plugins/texteffect/Makefile.am b/kopete/plugins/texteffect/Makefile.am
new file mode 100644
index 00000000..0d657dc5
--- /dev/null
+++ b/kopete/plugins/texteffect/Makefile.am
@@ -0,0 +1,20 @@
+METASOURCES = AUTO
+
+SUBDIRS = icons
+INCLUDES = $(KOPETE_INCLUDES) $(all_includes)
+
+kde_module_LTLIBRARIES = kopete_texteffect.la kcm_kopete_texteffect.la
+
+kopete_texteffect_la_SOURCES = texteffectplugin.cpp texteffectconfig.cpp
+kopete_texteffect_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kopete_texteffect_la_LIBADD = ../../libkopete/libkopete.la
+
+kcm_kopete_texteffect_la_SOURCES = texteffectconfig.cpp texteffectprefs.ui texteffectpreferences.cpp
+kcm_kopete_texteffect_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN) $(all_libraries)
+kcm_kopete_texteffect_la_LIBADD = ../../libkopete/libkopete.la $(LIB_KUTILS)
+
+service_DATA = kopete_texteffect.desktop
+servicedir = $(kde_servicesdir)
+
+kcm_DATA = kopete_texteffect_config.desktop
+kcmdir = $(kde_servicesdir)/kconfiguredialog