summaryrefslogtreecommitdiffstats
path: root/kpf/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
commitd36d9267539f12fdaa5a0dd18f6285e4a636e1ac (patch)
tree65966d4e78c0529e0e56f8586a7d9c2ae530d336 /kpf/CMakeLists.txt
parent54888da0ae983555ec963c52007c50d49b3c66af (diff)
downloadtdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.tar.gz
tdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kpf/CMakeLists.txt')
-rw-r--r--kpf/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/kpf/CMakeLists.txt b/kpf/CMakeLists.txt
index 3f1b82e2..198f8093 100644
--- a/kpf/CMakeLists.txt
+++ b/kpf/CMakeLists.txt
@@ -16,10 +16,14 @@ add_subdirectory( src )
tde_install_icons( kpf )
-install( FILES
- kpfapplet.desktop
- DESTINATION ${DATA_INSTALL_DIR}/kicker/applets )
+tde_create_translated_desktop(
+ SOURCE kpfapplet.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+ PO_DIR kpf-desktops
+)
-install( FILES
- kpfpropertiesdialogplugin.desktop
- DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kpfpropertiesdialogplugin.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kpf-desktops
+)