summaryrefslogtreecommitdiffstats
path: root/knewsticker/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'knewsticker/common/CMakeLists.txt')
-rw-r--r--knewsticker/common/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/knewsticker/common/CMakeLists.txt b/knewsticker/common/CMakeLists.txt
new file mode 100644
index 00000000..39305210
--- /dev/null
+++ b/knewsticker/common/CMakeLists.txt
@@ -0,0 +1,26 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### knewstickercommon (static) ################
+
+tde_add_library( knewstickercommon STATIC_PIC AUTOMOC
+ SOURCES
+ newsiconmgr.cpp xmlnewsaccess.cpp configaccess.cpp newsiconmgr.skel
+ newsengine.cpp
+)