summaryrefslogtreecommitdiffstats
path: root/kopete/kopete/config/identity/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/kopete/config/identity/Makefile.am')
-rw-r--r--kopete/kopete/config/identity/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kopete/kopete/config/identity/Makefile.am b/kopete/kopete/config/identity/Makefile.am
new file mode 100644
index 00000000..3f0fa409
--- /dev/null
+++ b/kopete/kopete/config/identity/Makefile.am
@@ -0,0 +1,15 @@
+METASOURCES = AUTO
+AM_CPPFLAGS = $(KOPETE_INCLUDES) $(KOPETE_COMPAT_INCLUDES) $(all_includes)
+
+kde_module_LTLIBRARIES = kcm_kopete_identityconfig.la
+
+kcm_kopete_identityconfig_la_SOURCES = kopeteidentityconfigbase.ui \
+ kopeteidentityconfig.cpp globalidentitiesmanager.cpp kopeteidentityconfigpreferences.kcfgc
+kcm_kopete_identityconfig_la_LDFLAGS = -no-undefined -module $(KDE_PLUGIN) $(all_libraries)
+kcm_kopete_identityconfig_la_LIBADD = -lkabc ../../../libkopete/libkopete.la $(LIB_KOPETECOMPAT) $(LIB_KUTILS)
+
+service_DATA = kopete_identityconfig.desktop
+servicedir = $(kde_servicesdir)
+
+# vim: set noet:
+kde_kcfg_DATA = kopeteidentityconfigpreferences.kcfg