summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/translator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/plugins/translator/CMakeLists.txt')
-rw-r--r--kopete/plugins/translator/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/kopete/plugins/translator/CMakeLists.txt b/kopete/plugins/translator/CMakeLists.txt
new file mode 100644
index 00000000..5dd274db
--- /dev/null
+++ b/kopete/plugins/translator/CMakeLists.txt
@@ -0,0 +1,51 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete
+ ${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kopete_translator.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES kopete_translator_config.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kconfiguredialog )
+install( FILES translatorui.rc translatorchatui.rc DESTINATION ${DATA_INSTALL_DIR}/kopete_translator )
+
+
+##### kopete_translator (module) ################
+
+tde_add_kpart( kopete_translator AUTOMOC
+ SOURCES
+ translatordialog.cpp translatorguiclient.cpp
+ translatorlanguages.cpp translatorplugin.cpp
+ LINK kopete-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### kcm_kopete_translator (module) ############
+
+tde_add_kpart( kcm_kopete_translator AUTOMOC
+ SOURCES
+ translatorprefsbase.ui translatorprefs.cpp
+ translatorlanguages.cpp
+ LINK kopete-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)