summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-09-01 12:36:09 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-09-01 12:36:09 +0200
commit40420b140dae57640a553643766112af9902b7b0 (patch)
tree77b8670df921d1c9c2bc22a5f713bb5fac2cf28f /CMakeLists.txt
parent7e43acd8185cad93e5aeb91b199a89bd8b3eb069 (diff)
downloadtdepacman-40420b140dae57640a553643766112af9902b7b0.tar.gz
tdepacman-40420b140dae57640a553643766112af9902b7b0.zip
Added controlled conversions to char* instead of automatic
ascii conversions. Removed unnecessary conversions to char*. The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 833e868..afd371c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,7 +59,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )