summaryrefslogtreecommitdiffstats
path: root/kaddressbook/editors/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /kaddressbook/editors/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kaddressbook/editors/CMakeLists.txt')
-rw-r--r--kaddressbook/editors/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/kaddressbook/editors/CMakeLists.txt b/kaddressbook/editors/CMakeLists.txt
index a2b8c898..09f91332 100644
--- a/kaddressbook/editors/CMakeLists.txt
+++ b/kaddressbook/editors/CMakeLists.txt
@@ -32,8 +32,17 @@ link_directories(
##### other data ################################
-install( FILES cryptosettings.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kaddressbook )
-install( FILES kaddressbookimprotocol.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE cryptosettings.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kaddressbook
+ PO_DIR kaddressbook-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE kaddressbookimprotocol.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kaddressbook-desktops
+)
##### kabim (static) ############################