summaryrefslogtreecommitdiffstats
path: root/kmobile/kioslave/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kmobile/kioslave/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kmobile/kioslave/Makefile.am')
-rw-r--r--kmobile/kioslave/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kmobile/kioslave/Makefile.am b/kmobile/kioslave/Makefile.am
new file mode 100644
index 00000000..6f9d2420
--- /dev/null
+++ b/kmobile/kioslave/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = mimetypes
+
+INCLUDES = -I$(top_srcdir)/kmobile -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = kio_mobile.la
+
+kio_mobile_la_SOURCES = kio_mobile.cpp
+kio_mobile_la_LIBADD = $(LIB_KIO) ../libkmobileclient.la
+kio_mobile_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -module $(KDE_PLUGIN)
+
+kde_services_DATA = mobile.protocol cellphone.protocol \
+ organizer.protocol pda.protocol
+# do not install the camera protocol now - we already have a
+# camera kioslave !!
+# phonecamera.protocol
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kio_mobile.pot