summaryrefslogtreecommitdiffstats
path: root/korganizer/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-10 20:45:10 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-10-10 20:45:10 +0000
commit0451bfa1dfdda10f7a0dc04277066f10648d37f8 (patch)
treee372421b17ffb8ec9944e753c504a84873cf604c /korganizer/Makefile.am
parentbd4d40e62f0ade42fbc594c1c87dfc93dfab8c99 (diff)
downloadtdepim-3.5.13.tar.gz
tdepim-3.5.13.zip
Link most Trinity DSOs against the most common kdelibs libraries to compensate for linking changes in modern distributions such as Ubuntu Oneiricv3.5.13
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1258263 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'korganizer/Makefile.am')
-rw-r--r--korganizer/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/korganizer/Makefile.am b/korganizer/Makefile.am
index c89d8b60..32c26bc8 100644
--- a/korganizer/Makefile.am
+++ b/korganizer/Makefile.am
@@ -14,7 +14,7 @@ INCLUDES = \
bin_PROGRAMS = korganizer
-korganizer_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+korganizer_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
korganizer_LDADD = libkorganizer.la
korganizer_SOURCES = main.cpp korganizer.cpp koapp.cpp
korganizer_COMPILE_FIRST = koprefs_base.h
@@ -36,12 +36,12 @@ libkorganizerpart_la_COMPILE_FIRST = publishdialog_base.h koprefs_base.h
check_PROGRAMS = korgplugins timezone
-korgplugins_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+korgplugins_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
korgplugins_LDADD = libkorganizer.la $(LIB_KSYCOCA)
korgplugins_SOURCES = korgplugins.cpp
korgplugins_COMPILE_FIRST = koprefs_base.h
-timezone_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+timezone_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_KDECORE) $(LIB_KDEUI) -lkdefx $(LIB_KIO) -lktexteditor
timezone_LDADD = libkorganizer.la $(LIB_KSYCOCA)
timezone_SOURCES = timezone.cpp
timezone_COMPILE_FIRST = koprefs_base.h