summaryrefslogtreecommitdiffstats
path: root/korganizer/interfaces/calendar/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /korganizer/interfaces/calendar/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'korganizer/interfaces/calendar/CMakeLists.txt')
-rw-r--r--korganizer/interfaces/calendar/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/korganizer/interfaces/calendar/CMakeLists.txt b/korganizer/interfaces/calendar/CMakeLists.txt
index fe5296fe..1e994d72 100644
--- a/korganizer/interfaces/calendar/CMakeLists.txt
+++ b/korganizer/interfaces/calendar/CMakeLists.txt
@@ -13,6 +13,8 @@ install( FILES
plugin.h calendardecoration.h
DESTINATION ${INCLUDE_INSTALL_DIR}/calendar )
-install( FILES
- calendarplugin.desktop calendardecoration.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE calendarplugin.desktop calendardecoration.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR korganizer-desktops
+)