summaryrefslogtreecommitdiffstats
path: root/korganizer/plugins/exchange/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-11 20:10:09 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-11 20:10:09 +0000
commit0d7351b5312d68b66f0481fe22b066a60c05a23a (patch)
tree883528313a6bdfc4b9a0d57ceb4db7e1ba3cf419 /korganizer/plugins/exchange/CMakeLists.txt
parentc1edef47add41611781ac9190d2b2bc8560c5a01 (diff)
downloadtdepim-0d7351b5312d68b66f0481fe22b066a60c05a23a.tar.gz
tdepim-0d7351b5312d68b66f0481fe22b066a60c05a23a.zip
[trinity/kdepim] initial cmake support for korganizer & dependencies
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1224515 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'korganizer/plugins/exchange/CMakeLists.txt')
-rw-r--r--korganizer/plugins/exchange/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/korganizer/plugins/exchange/CMakeLists.txt b/korganizer/plugins/exchange/CMakeLists.txt
new file mode 100644
index 00000000..8b5c8c7b
--- /dev/null
+++ b/korganizer/plugins/exchange/CMakeLists.txt
@@ -0,0 +1,41 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+tde_import( libkpimexchange )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/korganizer/interfaces
+ ${CMAKE_SOURCE_DIR}/libkdepim
+ ${CMAKE_SOURCE_DIR}/libkpimexchange/core
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES exchange.desktop DESTINATION ${SERVICES_INSTALL_DIR}/korganizer )
+install( FILES exchangeui.rc DESTINATION ${DATA_INSTALL_DIR}/korganizer/plugins )
+
+
+##### libkorg_exchange (module) #################
+
+tde_add_kpart( libkorg_exchange AUTOMOC
+ SOURCES exchange.cpp exchangedialog.cpp exchangeconfig.cpp
+ LINK korganizer-shared kpimexchange-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)