summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/memofileconduit/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitf4fae92b6768541e2952173c3d4b09040f95bf7e (patch)
treed8c5d93232235cd635f3310b4d95490df181ba2d /kpilot/conduits/memofileconduit/CMakeLists.txt
parent125c0a08265b75a133644d3b55f47e37c919f45d (diff)
downloadtdepim-f4fae92b6768541e2952173c3d4b09040f95bf7e.tar.gz
tdepim-f4fae92b6768541e2952173c3d4b09040f95bf7e.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpilot/conduits/memofileconduit/CMakeLists.txt')
-rw-r--r--kpilot/conduits/memofileconduit/CMakeLists.txt44
1 files changed, 0 insertions, 44 deletions
diff --git a/kpilot/conduits/memofileconduit/CMakeLists.txt b/kpilot/conduits/memofileconduit/CMakeLists.txt
deleted file mode 100644
index 56994570..00000000
--- a/kpilot/conduits/memofileconduit/CMakeLists.txt
+++ /dev/null
@@ -1,44 +0,0 @@
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
-)
-
-set(conduit_memofile_SRCS
- memofile-factory.cc
- memofile.cc
- memofiles.cc
- memofile-conduit.cc
-)
-
-set(conduit_memofile_UIS
- setup_base.ui
-)
-
-set(conduit_memofile_KCFGS
- memofileSettings.kcfgc
-)
-
-kde3_add_kcfg_files(conduit_memofile_SRCS ${conduit_memofile_KCFGS})
-kde3_add_ui_files(conduit_memofile_SRCS ${conduit_memofile_UIS})
-kde3_automoc(${conduit_memofile_SRCS})
-add_library(conduit_memofile SHARED ${conduit_memofile_SRCS})
-
-set_target_properties(
- conduit_memofile PROPERTIES LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib
- PREFIX ""
-)
-
-kde3_install_libtool_file(conduit_memofile)
-
-install(
- TARGETS conduit_memofile
- LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
-)
-
-install(
- FILES memofile-conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
-)
-
-install(
- FILES memofileconduit.kcfg DESTINATION ${KDE3_KCFG_DIR}
-)