summaryrefslogtreecommitdiffstats
path: root/kpilot/conduits/timeconduit/CMakeLists.txt
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitf4fae92b6768541e2952173c3d4b09040f95bf7e (patch)
treed8c5d93232235cd635f3310b4d95490df181ba2d /kpilot/conduits/timeconduit/CMakeLists.txt
parent125c0a08265b75a133644d3b55f47e37c919f45d (diff)
downloadtdepim-f4fae92b6768541e2952173c3d4b09040f95bf7e.tar.gz
tdepim-f4fae92b6768541e2952173c3d4b09040f95bf7e.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kpilot/conduits/timeconduit/CMakeLists.txt')
-rw-r--r--kpilot/conduits/timeconduit/CMakeLists.txt44
1 files changed, 0 insertions, 44 deletions
diff --git a/kpilot/conduits/timeconduit/CMakeLists.txt b/kpilot/conduits/timeconduit/CMakeLists.txt
deleted file mode 100644
index e980e724..00000000
--- a/kpilot/conduits/timeconduit/CMakeLists.txt
+++ /dev/null
@@ -1,44 +0,0 @@
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
-)
-
-set(conduit_time_SRCS
- time-conduit.cc
- time-factory.cc
- time-setup.cc
-)
-
-set(conduit_time_UIS
- time-setup_dialog.ui
-)
-
-set(conduit_time_KCFGS
- timeConduitSettings.kcfgc
-)
-
-kde3_add_kcfg_files(conduit_time_SRCS ${conduit_time_KCFGS})
-kde3_add_ui_files(conduit_time_SRCS ${conduit_time_UIS})
-kde3_automoc(${conduit_time_SRCS})
-add_library(conduit_time SHARED ${conduit_time_SRCS})
-
-kpilot_rpath(conduit_time)
-
-set_target_properties(
- conduit_time PROPERTIES LOCATION ${KDE3_PLUGIN_INSTALL_DIR}
- PREFIX ""
-)
-
-kde3_install_libtool_file(conduit_time)
-
-install(
- TARGETS conduit_time
- LIBRARY DESTINATION ${KDE3_PLUGIN_INSTALL_DIR}
-)
-
-install(
- FILES time_conduit.desktop DESTINATION ${KDE3_SERVICES_DIR}
-)
-
-install(
- FILES timeconduit.kcfg DESTINATION ${KDE3_KCFG_DIR}
-)