summaryrefslogtreecommitdiffstats
path: root/kresources/blogging/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kresources/blogging/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kresources/blogging/Makefile.am')
-rw-r--r--kresources/blogging/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/kresources/blogging/Makefile.am b/kresources/blogging/Makefile.am
new file mode 100644
index 00000000..b1572436
--- /dev/null
+++ b/kresources/blogging/Makefile.am
@@ -0,0 +1,29 @@
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/kresources/lib -I../lib -I$(top_srcdir)/kresources/blogging/libkblog/ $(all_includes)
+
+lib_LTLIBRARIES = libkcal_blogging.la
+kde_module_LTLIBRARIES = kcal_blogging.la
+
+libkcal_blogging_la_SOURCES = API_Blog.cpp API_Blogger.cpp xmlrpcjob.cpp \
+ bloggingglobals.cpp \
+ bloggingcalendaradaptor.cpp \
+ kcal_resourceblogging.cpp kcal_resourcebloggingconfig.cpp
+libkcal_blogging_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) \
+ -version-info 1:0:0 -no-undefined
+libkcal_blogging_la_LIBADD = \
+ ../lib/libkgroupwarebase.la \
+ $(top_builddir)/libkcal/libkcal.la $(top_builddir)/libkdepim/libkdepim.la
+
+
+kcal_blogging_la_SOURCES = kcal_resourceblogging_plugin.cpp
+kcal_blogging_la_LDFLAGS = $(all_libraries) -module -no-undefined $(KDE_PLUGIN)
+kcal_blogging_la_LIBADD = libkcal_blogging.la
+
+kcal_servicedir = $(kde_servicesdir)/kresources/kcal
+kcal_service_DATA = blogging.desktop
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kres_blogging.pot
+
+kcal_resourceblogging.lo: ../lib/kresources_groupwareprefs.h