summaryrefslogtreecommitdiffstats
path: root/kresources/groupware/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kresources/groupware/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kresources/groupware/Makefile.am')
-rw-r--r--kresources/groupware/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/kresources/groupware/Makefile.am b/kresources/groupware/Makefile.am
new file mode 100644
index 00000000..dfb12eec
--- /dev/null
+++ b/kresources/groupware/Makefile.am
@@ -0,0 +1,42 @@
+INCLUDES = -I$(top_srcdir) $(all_includes)
+
+lib_LTLIBRARIES = libkcal_groupware.la libkabc_groupware.la
+
+libkcal_groupware_la_SOURCES = kcal_resourcegroupware.cpp \
+ kcal_resourcegroupwareconfig.cpp \
+ kcal_groupwareprefsbase.kcfgc
+libkcal_groupware_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) \
+ -version-info 1:0:0 -no-undefined
+libkcal_groupware_la_LIBADD = \
+ $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/libkdepim/libkdepim.la
+
+libkabc_groupware_la_SOURCES = kabc_resourcegroupware.cpp \
+ kabc_resourcegroupwareconfig.cpp \
+ kabc_groupwareprefs.kcfgc
+libkabc_groupware_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) \
+ -version-info 1:0:0 -no-undefined
+libkabc_groupware_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/libkdepim/libkdepim.la \
+ -lkabc
+
+kde_module_LTLIBRARIES = kcal_groupware.la kabc_groupware.la
+
+kcal_groupware_la_SOURCES = kcal_resourcegroupware_plugin.cpp
+kcal_groupware_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kcal_groupware_la_LIBADD = libkcal_groupware.la
+
+kabc_groupware_la_SOURCES = kabc_resourcegroupware_plugin.cpp
+kabc_groupware_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kabc_groupware_la_LIBADD = libkabc_groupware.la
+
+kcal_servicedir = $(kde_servicesdir)/kresources/kcal
+kcal_service_DATA = kcal_groupware.desktop
+
+kabc_servicedir = $(kde_servicesdir)/kresources/kabc
+kabc_service_DATA = kabc_groupware.desktop
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kres_groupware.pot