summaryrefslogtreecommitdiffstats
path: root/kresources/groupwise/kioslave/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /kresources/groupwise/kioslave/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kresources/groupwise/kioslave/Makefile.am')
-rw-r--r--kresources/groupwise/kioslave/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kresources/groupwise/kioslave/Makefile.am b/kresources/groupwise/kioslave/Makefile.am
new file mode 100644
index 00000000..c944b3e5
--- /dev/null
+++ b/kresources/groupwise/kioslave/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/kresources/groupwise/soap \
+ -I$(top_builddir)/libkdepim $(all_includes)
+
+noinst_HEADERS = groupwise.h
+
+METASOURCES = AUTO
+
+kdelnkdir = $(kde_servicesdir)
+kdelnk_DATA = groupwise.protocol groupwises.protocol
+
+kde_module_LTLIBRARIES = kio_groupwise.la
+
+kio_groupwise_la_SOURCES = groupwise.cpp
+kio_groupwise_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ ../soap/libgwsoap.la $(top_builddir)/libkdepim/libkdepim.la $(LIB_KIO)
+kio_groupwise_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kio_groupwise.pot