summaryrefslogtreecommitdiffstats
path: root/tdeioslaves/mbox/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
commit64df902cf71a8ee258fb85f6be26248f399aa01f (patch)
treedba58f705042c22cea26b678d5b0e4e9a34bf202 /tdeioslaves/mbox/Makefile.am
parentde53c98cab07e9c4b0f5e25dab82830fb6fc67ec (diff)
downloadtdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.tar.gz
tdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslaves/mbox/Makefile.am')
-rw-r--r--tdeioslaves/mbox/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/tdeioslaves/mbox/Makefile.am b/tdeioslaves/mbox/Makefile.am
new file mode 100644
index 00000000..0fc50524
--- /dev/null
+++ b/tdeioslaves/mbox/Makefile.am
@@ -0,0 +1,30 @@
+INCLUDES= $(all_includes)
+
+####### Files
+
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kio_mbox.la
+
+kio_mbox_la_SOURCES = \
+ mbox.cc \
+ mboxfile.cc \
+ readmbox.cc \
+ stat.cc \
+ urlinfo.cc
+kio_mbox_la_LIBADD = $(LIB_KIO) $(LIB_QT) $(LIB_TDECORE)
+kio_mbox_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -module $(KDE_PLUGIN)
+
+noinst_HEADERS = \
+ mbox.h \
+ mboxfile.h \
+ readmbox.h \
+ stat.h \
+ urlinfo.h
+
+kdelnk_DATA = mbox.protocol
+kdelnkdir = $(kde_servicesdir)
+
+
+include $(top_srcdir)/admin/Doxyfile.am
+