summaryrefslogtreecommitdiffstats
path: root/tderesources/groupdav/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
commitb363d2579af0a11b77e698aed2e1021c2233b644 (patch)
treef4a47b87354b7a6a3b266c8121bd8ddaeb7accaa /tderesources/groupdav/Makefile.am
parent61bddfe3a7226b18c68a76124b727c736f431688 (diff)
downloadtdepim-b363d2579af0a11b77e698aed2e1021c2233b644.tar.gz
tdepim-b363d2579af0a11b77e698aed2e1021c2233b644.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tderesources/groupdav/Makefile.am')
-rw-r--r--tderesources/groupdav/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/tderesources/groupdav/Makefile.am b/tderesources/groupdav/Makefile.am
new file mode 100644
index 00000000..1e20f291
--- /dev/null
+++ b/tderesources/groupdav/Makefile.am
@@ -0,0 +1,52 @@
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/tderesources/lib \
+ -I../lib $(all_includes)
+
+lib_LTLIBRARIES = libkcal_groupdav.la libkabc_groupdav.la
+noinst_LTLIBRARIES = libkgroupdav.la
+
+libkgroupdav_la_SOURCES = groupdavglobals.cpp
+
+libkcal_groupdav_la_SOURCES = groupdavcalendaradaptor.cpp kcal_resourcegroupdav.cpp
+libkcal_groupdav_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) \
+ -version-info 1:0:0 -no-undefined
+libkcal_groupdav_la_LIBADD = \
+ libkgroupdav.la ../lib/libkgroupwaredav.la \
+ $(top_builddir)/libkcal/libkcal.la $(top_builddir)/libtdepim/libtdepim.la
+
+libkabc_groupdav_la_SOURCES = kabc_resourcegroupdav.cpp groupdavaddressbookadaptor.cpp
+libkabc_groupdav_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) \
+ -version-info 1:0:0 -no-undefined
+libkabc_groupdav_la_LIBADD = \
+ libkgroupdav.la ../lib/libkgroupwaredav.la \
+ $(top_builddir)/libkcal/libkcal.la $(top_builddir)/libtdepim/libtdepim.la \
+ -lkabc
+
+kde_module_LTLIBRARIES = kcal_groupdav.la kabc_groupdav.la
+
+kcal_groupdav_la_SOURCES = kcal_resourcegroupdav_plugin.cpp
+kcal_groupdav_la_LDFLAGS = $(all_libraries) -module -no-undefined $(KDE_PLUGIN)
+kcal_groupdav_la_LIBADD = libkcal_groupdav.la
+
+kabc_groupdav_la_SOURCES = kabc_resourcegroupdav_plugin.cpp
+kabc_groupdav_la_LDFLAGS = $(all_libraries) -module -no-undefined $(KDE_PLUGIN)
+kabc_groupdav_la_LIBADD = libkabc_groupdav.la
+
+kcal_servicedir = $(kde_servicesdir)/tderesources/kcal
+kcal_service_DATA = kcal_groupdav.desktop
+
+kabc_servicedir = $(kde_servicesdir)/tderesources/kabc
+kabc_service_DATA = kabc_groupdav.desktop
+
+METASOURCES = AUTO
+
+install-data-local: uninstall.desktop
+ $(mkinstalldirs) $(DESTDIR)$(kde_servicesdir)/tderesources/kabc
+ $(mkinstalldirs) $(DESTDIR)$(kde_servicesdir)/tderesources/kcal
+ $(INSTALL_DATA) $(srcdir)/uninstall.desktop $(DESTDIR)$(kde_servicesdir)/tderesources/kabc/kabc_opengroupware.desktop
+ $(INSTALL_DATA) $(srcdir)/uninstall.desktop $(DESTDIR)$(kde_servicesdir)/tderesources/kcal/kcal_opengroupware.desktop
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kres_groupdav.pot
+
+kabc_resourcegroupdav.lo: ../lib/tderesources_groupwareprefs.h
+