summaryrefslogtreecommitdiffstats
path: root/tderesources/newexchange/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /tderesources/newexchange/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tderesources/newexchange/CMakeLists.txt')
-rw-r--r--tderesources/newexchange/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/tderesources/newexchange/CMakeLists.txt b/tderesources/newexchange/CMakeLists.txt
index 4680a73a..975093b8 100644
--- a/tderesources/newexchange/CMakeLists.txt
+++ b/tderesources/newexchange/CMakeLists.txt
@@ -26,8 +26,17 @@ link_directories(
##### other data ################################
-install( FILES kcal_newexchange.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/kcal )
-install( FILES tdeabc_newexchange.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/tdeabc )
+tde_create_translated_desktop(
+ SOURCE kcal_newexchange.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/kcal
+ PO_DIR tderesources-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE tdeabc_newexchange.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/tdeabc
+ PO_DIR tderesources-desktops
+)
##### kcal_newexchange (module) #################