summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..432530c
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,53 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${DBUS_INCLUDE_DIRS}
+ ${HAL_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+tde_install_icons( kpowersave )
+install( FILES kpowersave.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+install( FILES kpowersave-autostart.desktop DESTINATION ${AUTOSTART_INSTALL_DIR} )
+install( FILES eventsrc DESTINATION ${DATA_INSTALL_DIR}/kpowersave )
+install( FILES config/kpowersaverc_default RENAME kpowersaverc DESTINATION ${CONFIG_INSTALL_DIR} )
+
+
+##### kpowersave (kdeinit) ######################
+
+tde_add_kdeinit_executable( kpowersave AUTOMOC
+ SOURCES
+ dummy.cpp autodimm.cpp autosuspend.cpp
+ blacklistedit_Dialog.ui blacklisteditdialog.cpp
+ configure_Dialog.ui configuredialog.cpp countdown_Dialog.ui
+ countdowndialog.cpp dbusHAL.cpp detailed_Dialog.ui
+ detaileddialog.cpp hardware.cpp hardware_battery.cpp
+ hardware_batteryCollection.cpp hardware_cpu.cpp
+ inactivity.cpp info_Dialog.ui infodialog.cpp kpowersave.cpp
+ kpowersave.skel log_viewer.ui logviewer.cpp main.cpp
+ screen.cpp settings.cpp suspenddialog.cpp suspend_Dialog.ui
+ LINK
+ dbus-qt-1 kio-shared ${DBUS_LIBRARIES} ${HAL_LIBRARIES}
+ ${XEXT_LIBRARIES} ${XTST_LIBRARIES} ${XSCRNSAVER_LIBRARIES}
+)