summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am102
1 files changed, 0 insertions, 102 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 9c7b044..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,102 +0,0 @@
-# set the include path for X, qt and KDE
-INCLUDES = \
- -DPACKAGE_KDE_SOUND_DIR=\""$(prefix)/share/sounds/"\" \
- $(all_includes) \
- @PACKAGE_CFLAGS@
-
-# these are the headers for your project
-noinst_HEADERS = \
- autodimm.h \
- autosuspend.h \
- blacklisteditdialog.h \
- configuredialog.h \
- countdowndialog.h \
- dbusInterface.h \
- detaileddialog.h \
- hardware.h \
- hardware_battery.h \
- hardware_batteryCollection.h \
- hardware_cpu.h \
- inactivity.h \
- infodialog.h \
- tdepowersave.h \
- logviewer.h \
- screen.h \
- settings.h \
- suspenddialog.h
-
-
-# let automoc handle all of the meta source files (moc)
-METASOURCES = AUTO
-
-KDE_ICON = tdepowersave
-
-#########################################################################
-# APPLICATION SECTION
-#########################################################################
-# this is the program that gets installed. it's name is used for all
-# of the other Makefile.am variables
-
-bin_PROGRAMS =
-lib_LTLIBRARIES =
-tdeinit_LTLIBRARIES = tdepowersave.la
-
-# the application source, library search path, and link libraries
-tdepowersave_la_SOURCES = \
- dummy.cpp \
- autodimm.cpp \
- autosuspend.cpp \
- blacklistedit_Dialog.ui \
- blacklisteditdialog.cpp \
- configure_Dialog.ui \
- configuredialog.cpp \
- countdown_Dialog.ui \
- countdowndialog.cpp \
- dbusInterface.cpp \
- detailed_Dialog.ui \
- detaileddialog.cpp \
- hardware.cpp \
- hardware_battery.cpp \
- hardware_batteryCollection.cpp \
- hardware_cpu.cpp \
- inactivity.cpp \
- info_Dialog.ui \
- infodialog.cpp \
- tdepowersave.cpp \
- tdepowersave.skel \
- log_viewer.ui \
- logviewer.cpp \
- main.cpp \
- screen.cpp \
- settings.cpp \
- suspenddialog.cpp \
- suspend_Dialog.ui
-
-
-tdepowersave_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -module -avoid-version
-tdepowersave_la_LIBADD = $(LIB_TDEIO) @PACKAGE_LIBS@ -ldbus-tqt-1 -lXss -lXext -lXtst
-
-# this is where the desktop file will go
-xdg_apps_DATA = tdepowersave.desktop
-
-# and for autostart
-autostartdir = $(prefix)/share/autostart
-autostart_DATA = tdepowersave-autostart.desktop
-
-# this is where the shell's XML-GUI resource file goes
-shellrcdir = $(kde_datadir)/tdepowersave
-shellrc_DATA = eventsrc
-# shellrc_DATA = tdepowersaveui.rc
-
-# pics subdir
-SUBDIRS = pics
-messages:
- $(EXTRACTRC) *ui eventsrc >> rc.cpp
- $(XGETTEXT) `find . -name \*.h -o -name \*.H -o -name \*.cpp -o -name \*.C` -o $(podir)/tdepowersave.pot
- rm -f rc.cpp
-
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(kde_confdir)
- $(INSTALL_DATA) $(top_srcdir)/src/config/tdepowersaverc_default $(DESTDIR)$(kde_confdir)/tdepowersaverc
-
-