summaryrefslogtreecommitdiffstats
path: root/convert-presets/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2022-05-30 19:40:31 +0900
committerSlávek Banko <slavek.banko@axis.cz>2022-05-30 21:55:12 +0200
commit9d7329284fd42187092c829ae6ed030561002776 (patch)
tree1d53503d17938eca725caee7ff783fccf52ca509 /convert-presets/Makefile.am
parentfac82f62f156c76cb4b23c313111283b30a778b5 (diff)
downloadtderadio-9d732928.tar.gz
tderadio-9d732928.zip
Standardize folder structure.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit d95a4fea540b371fa86493d069fdbd54f33c5b40)
Diffstat (limited to 'convert-presets/Makefile.am')
-rw-r--r--convert-presets/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/convert-presets/Makefile.am b/convert-presets/Makefile.am
new file mode 100644
index 0000000..358a58d
--- /dev/null
+++ b/convert-presets/Makefile.am
@@ -0,0 +1,31 @@
+subdirs = po .
+
+bin_PROGRAMS = convert-presets
+
+convert_presets_SOURCES = convert-presets.cpp
+convert_presets_LDADD = $(LIB_TDEFILE) $(LIB_TDEUI) $(LIB_TDECORE)
+
+
+# this 10 paths are KDE specific. Use them:
+# kde_htmldir Where your docs should go to. (contains lang subdirs)
+# kde_appsdir Where your application file (.kdelnk) should go to.
+# kde_icondir Where your icon should go to.
+# kde_minidir Where your mini icon should go to.
+# kde_datadir Where you install application data. (Use a subdir)
+# kde_locale Where translation files should go to.(contains lang subdirs)
+# kde_cgidir Where cgi-bin executables should go to.
+# kde_confdir Where config files should go to.
+# kde_mimedir Where mimetypes should go to.
+# kde_toolbardir Where general toolbar icons should go to.
+# kde_wallpaperdir Where general wallpapers should go to.
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+
+METASOURCES = AUTO
+
+# the library search path.
+convert_presets_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o po/tderadio-convert-presets.pot