summaryrefslogtreecommitdiffstats
path: root/plugins/alsa-sound/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/alsa-sound/Makefile.am')
-rw-r--r--plugins/alsa-sound/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/alsa-sound/Makefile.am b/plugins/alsa-sound/Makefile.am
new file mode 100644
index 0000000..dfc2b0b
--- /dev/null
+++ b/plugins/alsa-sound/Makefile.am
@@ -0,0 +1,20 @@
+SUBDIRS = po icons .
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+libtderadio_LTLIBRARIES = libalsa-sound.la
+libalsa_sound_la_LDFLAGS = -module -avoid-version $(KDE_RPATH) $(all_libraries)
+noinst_HEADERS = alsa-sound.h alsa-sound-configuration.h alsa-mixer-element.h \
+ alsa-config-mixer-setting.h
+libalsa_sound_la_SOURCES = alsa-sound.cpp alsa-sound-configuration-ui.ui \
+ alsa-sound-configuration.cpp alsa-mixer-element-ui.ui alsa-mixer-element.cpp \
+ alsa-config-mixer-setting.cpp
+libalsa_sound_la_LIBADD = $(LIB_ALSA)
+
+#messages: rc.cpp
+# $(XGETTEXT) *.cpp *.h -o po/tderadio-alsa-sound.pot
+
+messages: rc.cpp
+ $(EXTRACTRC) *.rc *.ui >> rc.cpp
+ $(XGETTEXT) rc.cpp *.h *.cpp -o po/tderadio-alsa-sound.pot