summaryrefslogtreecommitdiffstats
path: root/plugins/gui-quickbar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/gui-quickbar/Makefile.am')
-rw-r--r--plugins/gui-quickbar/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/plugins/gui-quickbar/Makefile.am b/plugins/gui-quickbar/Makefile.am
new file mode 100644
index 0000000..c43d957
--- /dev/null
+++ b/plugins/gui-quickbar/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = po .
+
+INCLUDES = -I$(top_builddir)/src $(all_includes)
+METASOURCES = AUTO
+
+libtderadio_LTLIBRARIES = libquickbar.la
+libquickbar_la_SOURCES = buttonflowlayout.cpp quickbar.cpp \
+ quickbar-configuration.cpp
+libquickbar_la_LDFLAGS = -module -avoid-version $(KDE_RPATH) $(all_libraries)
+
+noinst_HEADERS = buttonflowlayout.h quickbar-configuration.h quickbar.h
+
+#messages: rc.cpp
+# $(XGETTEXT) *.cpp *.h -o po/tderadio-gui-quickbar.pot
+
+messages: rc.cpp
+ $(EXTRACTRC) *.rc *.ui >> rc.cpp
+ $(XGETTEXT) rc.cpp *.h *.cpp -o po/tderadio-gui-quickbar.pot