summaryrefslogtreecommitdiffstats
path: root/plugins/timeshifter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/timeshifter/Makefile.am')
-rw-r--r--plugins/timeshifter/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/plugins/timeshifter/Makefile.am b/plugins/timeshifter/Makefile.am
new file mode 100644
index 0000000..38d99cb
--- /dev/null
+++ b/plugins/timeshifter/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = po icons .
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+libtderadio_LTLIBRARIES = libtimeshifter.la
+libtimeshifter_la_SOURCES = timeshifter.cpp timeshifter-configuration-ui.ui \
+ timeshifter-configuration.cpp
+libtimeshifter_la_LDFLAGS = -module -avoid-version $(KDE_RPATH) $(all_libraries)
+
+noinst_HEADERS = timeshifter.h timeshifter-configuration.h
+
+#messages: rc.cpp
+# $(XGETTEXT) *.cpp *.h -o po/tderadio-timeshifter.pot
+
+messages: rc.cpp
+ $(EXTRACTRC) *.rc *.ui >> rc.cpp
+ $(XGETTEXT) rc.cpp *.h *.cpp -o po/tderadio-timeshifter.pot