summaryrefslogtreecommitdiffstats
path: root/kspy/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbd9e6617827818fd043452c08c606f07b78014a0 (patch)
tree425bb4c3168f9c02f10150f235d2cb998dcc6108 /kspy/Makefile.am
downloadtdesdk-bd9e6617827818fd043452c08c606f07b78014a0.tar.gz
tdesdk-bd9e6617827818fd043452c08c606f07b78014a0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdesdk@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kspy/Makefile.am')
-rw-r--r--kspy/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/kspy/Makefile.am b/kspy/Makefile.am
new file mode 100644
index 00000000..37af3c20
--- /dev/null
+++ b/kspy/Makefile.am
@@ -0,0 +1,30 @@
+
+lib_LTLIBRARIES = libkspy.la
+libkspy_la_SOURCES = navviewitem.cpp propsview.cpp navview.cpp spy.cpp sigslotview.cpp \
+ receiversview.cpp classinfoview.cpp
+
+include_HEADERS = kspy.h
+
+noinst_HEADERS = spy.h navview.h propsview.h navviewitem.h receiversview.h classinfoview.h
+
+libkspy_la_LIBADD = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIBSOCKET)
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+
+libkspy_la_LDFLAGS = $(all_libraries) -version-info 3:0:2 -no-undefined $(USER_LDFLAGS)
+
+EXTRA_DIST = main.cpp spy.cpp spy.h navview.cpp navview.h propsview.cpp \
+ propsview.h navviewitem.cpp navviewitem.h sigslotview.h receiversview.h classinfoview.h
+
+METASOURCES = AUTO
+
+messages:
+ LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \
+ if test -n "$$LIST"; then \
+ $(XGETTEXT) $$LIST -o $(podir)/spy.pot; \
+ fi
+
+check_PROGRAMS = testkspy
+testkspy_SOURCES = main.cpp
+testkspy_LDADD = libkspy.la