summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-02-14 16:30:32 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-02-15 10:58:25 +0900
commit57be2f09e26a5eec6a4a810f070658b98e11120c (patch)
tree4ee1a372a71cd219ad08a042a3aa40cad4c38d43 /CMakeLists.txt
parent4d99f29ac3beb7e9501153797e83eceb89307256 (diff)
downloadtdeutils-57be2f09e26a5eec6a4a810f070658b98e11120c.tar.gz
tdeutils-57be2f09e26a5eec6a4a810f070658b98e11120c.zip
Simplify code since cmake minimum version is now 3.5
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b962b6d..c84caa7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,14 +133,8 @@ option( BUILD_TDEFILEREPLACE "Build tdefilereplace" ${BUILD_ALL} )
##### add apidox targets ############
-if( "${CMAKE_VERSION}" VERSION_LESS "3.1" )
- set( CMAKE_ENV "env" )
-else()
- set( CMAKE_ENV "${CMAKE_COMMAND};-E;env" )
-endif()
-
add_custom_target( apidox
- COMMAND ${CMAKE_ENV}
+ COMMAND ${CMAKE_COMMAND} -E env
"TQTDOCDIR=/usr/share/tqt3/doc/html"
"DOXDATA=${HTML_INSTALL_DIR}/en/common"
${CMAKE_SOURCE_DIR}/admin/doxygen.sh