summaryrefslogtreecommitdiffstats
path: root/ark/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2012-11-10 20:47:02 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2012-11-10 20:47:02 -0600
commitc1a8ee04fbfe9851c1f788bcdcf3a5339ce1e478 (patch)
treeb60bf0191b08974e1ad29fd808d298aaeb29ef5a /ark/CMakeLists.txt
parent42177b2709de3eb2ef8ecde7d2a027fbb05a218c (diff)
downloadtdeutils-c1a8ee04fbfe9851c1f788bcdcf3a5339ce1e478.tar.gz
tdeutils-c1a8ee04fbfe9851c1f788bcdcf3a5339ce1e478.zip
Initial conversion to cmake.
Thanks to Fat-Zer.
Diffstat (limited to 'ark/CMakeLists.txt')
-rw-r--r--ark/CMakeLists.txt85
1 files changed, 85 insertions, 0 deletions
diff --git a/ark/CMakeLists.txt b/ark/CMakeLists.txt
new file mode 100644
index 0000000..4eae607
--- /dev/null
+++ b/ark/CMakeLists.txt
@@ -0,0 +1,85 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+add_definitions(
+ -D_LARGEFILE64_SOURCE
+)
+
+
+##### ark_common (static) #######################
+
+tde_add_library( ark_common STATIC_PIC
+ SOURCES settings.kcfgc archiveformatinfo.cpp
+)
+
+
+##### ark (tdeinit) #############################
+
+tde_add_tdeinit_executable( ark AUTOMOC
+ SOURCES main.cpp arkapp.cpp mainwindow.cpp
+ LINK ark_common-static khtml-shared
+)
+
+
+##### arkpart (kpart) ###########################
+
+tde_add_kpart( arkpart AUTOMOC
+ SOURCES ark_part.cpp arkfactory.cpp zip.cpp
+ tar.cpp filelistview.cpp arch.cpp lha.cpp
+ compressedfile.cpp zoo.cpp rar.cpp ar.cpp
+ arkutils.cpp archiveformatdlg.cpp
+ arkwidget.cpp searchbar.cpp addition.ui
+ extraction.ui general.ui arkviewer.cpp
+ sevenzip.cpp extractiondialog.cpp ace.cpp
+ tarlistingthread.cpp arj.cpp
+ LINK ark_common-static khtml-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( ark )
+
+
+##### other data ################################
+
+install( FILES arkui.rc ark_part.rc
+ ark_part_readonly.rc
+ DESTINATION ${DATA_INSTALL_DIR}/ark
+)
+
+install( FILES ark.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install( FILES ark_part.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)
+
+install( FILES ark.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)
+