summaryrefslogtreecommitdiffstats
path: root/khexedit/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit2bda8f7717adf28da4af0d34fb82f63d2868c31d (patch)
tree8d927b7b47a90c4adb646482a52613f58acd6f8c /khexedit/Makefile.am
downloadtdeutils-2bda8f7717adf28da4af0d34fb82f63d2868c31d.tar.gz
tdeutils-2bda8f7717adf28da4af0d34fb82f63d2868c31d.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeutils@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'khexedit/Makefile.am')
-rw-r--r--khexedit/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/khexedit/Makefile.am b/khexedit/Makefile.am
new file mode 100644
index 0000000..bacaa75
--- /dev/null
+++ b/khexedit/Makefile.am
@@ -0,0 +1,35 @@
+INCLUDES = $(all_includes)
+
+SUBDIRS = pics lib parts
+
+bin_PROGRAMS = khexedit
+
+khexedit_SOURCES = main.cc toplevel.cc hexmanagerwidget.cc \
+hexeditorwidget.cc hextoolwidget.cc hexviewwidget.cc hexbuffer.cc \
+conversion.cc dialog.cc hexvalidator.cc hexclipboard.cc \
+optiondialog.cc printdialogpage.cc statusbarprogress.cc \
+hexprinter.cc hexerror.cc draglabel.cc stringdialog.cc \
+bitswapwidget.cc chartabledialog.cc hexdrag.cc exportdialog.cc \
+fileinfodialog.cc converterdialog.cc listview.cc searchbar.cc
+
+noinst_HEADERS = toplevel.h hexmanagerwidget.h hexeditorwidget.h \
+hextoolwidget.h hexviewwidget.h hexbuffer.h conversion.h dialog.h \
+hexvalidator.h hexclipboard.h optiondialog.h \
+printdialogpage.h statusbarprogress.h hexprinter.h hexerror.h \
+draglabel.h progress.h hexeditstate.h chartabledialog.h hexdrag.h \
+exportdialog.h fileinfodialog.h converterdialog.h listview.h searchbar.h
+
+khexedit_METASOURCES = AUTO
+khexedit_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+khexedit_LDADD = $(LIB_KIO) $(LIB_KDEPRINT)
+
+xdg_apps_DATA = khexedit.desktop
+
+KDE_ICON = khexedit
+
+rcdir = $(kde_datadir)/khexedit
+rc_DATA = khexeditui.rc
+
+messages: rc.cpp
+ $(EXTRACTRC) parts/kpart/*rc >> rc.cpp
+ $(XGETTEXT) rc.cpp `find . -name \*.cc -o -name \*.cpp` -o $(podir)/khexedit.pot