summaryrefslogtreecommitdiffstats
path: root/tdewallet/konfigurator/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:18:06 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:18:06 -0600
commit79fd2b2bbd9f842ce3c84c67e3314033a9cceea4 (patch)
treed6d2174614dc2384de6f77a930aaf3d06b276fae /tdewallet/konfigurator/Makefile.am
parentc3e3301aba81e1c1771fa309941888a8b0fb59bc (diff)
downloadtdeutils-79fd2b2bbd9f842ce3c84c67e3314033a9cceea4.tar.gz
tdeutils-79fd2b2bbd9f842ce3c84c67e3314033a9cceea4.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdewallet/konfigurator/Makefile.am')
-rw-r--r--tdewallet/konfigurator/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tdewallet/konfigurator/Makefile.am b/tdewallet/konfigurator/Makefile.am
new file mode 100644
index 0000000..b7fa556
--- /dev/null
+++ b/tdewallet/konfigurator/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kcm_tdewallet.la
+kcm_tdewallet_la_SOURCES = walletconfigwidget.ui konfigurator.cpp
+kcm_tdewallet_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_tdewallet_la_LIBADD = $(LIB_TDEUI) -ltdewalletclient
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmtdewallet.pot
+
+xdg_apps_DATA = tdewalletconfig.desktop
+
+kde_services_DATA = tdewallet_config.desktop tdewalletmanager_show.desktop
+