summaryrefslogtreecommitdiffstats
path: root/kcalc/knumber/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcalc/knumber/Makefile.am')
-rw-r--r--kcalc/knumber/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/kcalc/knumber/Makefile.am b/kcalc/knumber/Makefile.am
new file mode 100644
index 0000000..6e5673b
--- /dev/null
+++ b/kcalc/knumber/Makefile.am
@@ -0,0 +1,16 @@
+AM_CPPFLAGS=-D_GNU_SOURCE -D_ISOC99_SOURCE $(all_includes)
+
+SUBDIRS = tests
+
+bin_PROGRAMS =
+lib_LTLIBRARIES =
+noinst_LTLIBRARIES = libknumber.la
+
+libknumber_la_SOURCES = knumber.cpp knumber_priv.cpp
+libknumber_la_LIBADD = $(LIBGMP) -lm
+
+METASOURCES = AUTO
+
+noinst_HEADERS = knumber.h knumber_priv.h
+
+include ../../admin/Doxyfile.am