summaryrefslogtreecommitdiffstats
path: root/khexedit/parts/kbytesedit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'khexedit/parts/kbytesedit/CMakeLists.txt')
-rw-r--r--khexedit/parts/kbytesedit/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/khexedit/parts/kbytesedit/CMakeLists.txt b/khexedit/parts/kbytesedit/CMakeLists.txt
new file mode 100644
index 0000000..b6d70e0
--- /dev/null
+++ b/khexedit/parts/kbytesedit/CMakeLists.txt
@@ -0,0 +1,41 @@
+#################################################
+#
+# (C) 2012 Golubev Alexander
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/khexedit/lib
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${CMAKE_BINARY_DIR}/khexedit/lib
+)
+
+
+##### kbyteseditwidget (kpart) ##################
+
+tde_add_kpart( kbyteseditwidget AUTOMOC
+ SOURCES kbyteseditwidget.cpp
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+ LINK khexeditcommon-shared kparts-shared
+)
+
+
+##### other data ################################
+
+install( FILES kbyteseditwidget.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)
+