summaryrefslogtreecommitdiffstats
path: root/kjots/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kjots/Makefile.am')
-rw-r--r--kjots/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/kjots/Makefile.am b/kjots/Makefile.am
new file mode 100644
index 0000000..32af728
--- /dev/null
+++ b/kjots/Makefile.am
@@ -0,0 +1,28 @@
+INCLUDES = $(all_includes)
+AM_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+LDADD = $(LIB_KFILE) $(LIB_KDEPRINT)
+
+bin_PROGRAMS = kjots
+
+kjots_SOURCES = main.cpp\
+ KJotsMain.cpp\
+ kjotsentry.cpp\
+ kjotsedit.cpp\
+ kjotsbookmarks.cpp\
+ confpagefont.ui\
+ confpagemisc.ui \
+ KJotsSettings.kcfgc
+
+kjots_METASOURCES = AUTO
+
+SUBDIRS = icons
+
+xdg_apps_DATA = Kjots.desktop
+kde_kcfg_DATA = kjots.kcfg
+
+rcdir = $(kde_datadir)/kjots
+rc_DATA = kjotsui.rc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kjots.pot
+