summaryrefslogtreecommitdiffstats
path: root/languages/cpp/app_templates/tdefileplugin/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:06:29 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:06:29 -0600
commitc0b24fe164924298d7e6ae33964b3c65fadbcba3 (patch)
tree2ba50375d78b077b266b224e4413150ef3e60a15 /languages/cpp/app_templates/tdefileplugin/Makefile.am
parent33d15e862e09fbcbb05e209f832414bd8a01291e (diff)
downloadtdevelop-c0b24fe164924298d7e6ae33964b3c65fadbcba3.tar.gz
tdevelop-c0b24fe164924298d7e6ae33964b3c65fadbcba3.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'languages/cpp/app_templates/tdefileplugin/Makefile.am')
-rw-r--r--languages/cpp/app_templates/tdefileplugin/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/languages/cpp/app_templates/tdefileplugin/Makefile.am b/languages/cpp/app_templates/tdefileplugin/Makefile.am
new file mode 100644
index 00000000..019d2d7c
--- /dev/null
+++ b/languages/cpp/app_templates/tdefileplugin/Makefile.am
@@ -0,0 +1,18 @@
+dataFiles = README.devel tdefile_plugin.cpp tdefile_plugin.desktop \
+ tdefile_plugin.h plugin.tdevelop tdefileplugin tdefileplugin.png \
+ src-Makefile.am subdirs
+templateName = tdefileplugin
+
+### no need to change below:
+template_DATA = $(templateName).kdevtemplate
+templatedir = ${appwizarddatadir}/templates
+
+appwizarddatadir = ${kde_datadir}/kdevappwizard
+$(templateName).tar.gz: ${dataFiles}
+ $(TAR) -cf $(templateName).tar -C $(srcdir) ${dataFiles}
+ $(GZIP_COMMAND) -f9 $(templateName).tar
+
+archivedir = ${appwizarddatadir}
+archive_DATA = $(templateName).tar.gz ${templateName}.png
+
+CLEANFILES = *.tar.gz \ No newline at end of file